Webmail server is busy
Incident Report for Flexstar Hosting Malaysia
Resolved
This incident has been resolved.
Posted Oct 11, 2024 - 20:39 GMT+08:00
Update
We are continuing to investigate this issue.
Posted Oct 11, 2024 - 20:34 GMT+08:00
Investigating
We are currently investigating this issue.
Posted Oct 11, 2024 - 17:24 GMT+08:00
This incident affected: Webmail Client.